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ABSTRACT 
Accurate identification and classifica- tion of glomeruli in renal biopsy specimens are 
fundamental for histopathological diagnosis and chronic kidney disease staging. While 
deep learning (DL) methodologies have advanced au- tomated segmentation, their 
reliance on exten- sive computational resources, large annotated datasets, and 
specialized expertise limits acces- sibility. This study introduces a standardized, open-
source framework for glomerular segmenta- tion and sclerosis classification using 
ImageJ, cir- cumventing these barriers. Our pipeline inte- grates preprocessing, 
segmentation, and quantita- tive morphometric analysis to discriminate scle- rotic from 
non-sclerotic glomeruli based on struc- tural and textural biomarkers. The proposed 
method was validated using established perfor- mance metrics—Accuracy, Precision, 
Recall, and Intersection-over-Union (IoU)—on renal biopsy images. When benchmarked 
against contempo- rary DL-based segmentation techniques, our Im- ageJ workflow 
achieved comparable efficacy, while demonstrating superior computational efficiency, 
implementation simplicity, and methodological transparency. These results establish 
ImageJ as a practical, high-performance tool for glomeru- lar segmentation in renal 
pathology. The vali- dated workflow offers pathologists and researchers a resource-
minimal, accessible alternative to com- putationally intensive DL systems, promoting 
scal- able adoption in clinical diagnostics and trans- lational research for objective 
histopathological quantification. 
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1. INTRODUCTION 
Diabetic nephropathy (DN) affects approximately 40 per- cent of diabetes patients and represents a leading cause 

of end-stage renal disease worldwide. Histopathological eval- uation of renal biopsies remains the gold standard for di- 
agnosing DN progression, where the quantification of scle- rotic glomeruli—characterized by mesangial matrix 
expansion, nodular Kimmelstiel-Wilson lesions, and basement membrane thickening—serves as a critical prognostic 
indicator. Con- versely, non-sclerotic glomeruli reflect earlier disease stages with preserved functional potential. 
Accurate differentiation between these classes is essential for clinical decision-making, yet manual assessment suffers 
from significant inter-observer variability (=0.65–0.78) and time-intensive analysis (15–25 minutes per biopsy). While 
deep learning (DL) methods have emerged for automated glomerular segmentation, their clin- ical adoption faces 
substantial barriers: Resource intensity: Dependency on GPU hardware (¿15,000 dollars) and cloud computing Data 
hunger: Requirement for 500–2,000 expert- annotated training samples Operational opacity: ”Black-box” decision 
processes that hinder pathological validation To ad- dress these limitations, this study leverages ImageJ—an open- 
source, platform-independent bioimage analysis tool—with its Labkit plugin to develop an accessible framework for seg- 
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menting and classifying sclerotic/non-sclerotic glomeruli. Our methodology integrates: Morphometric analysis of 
glomeru- lar area, circularity, and solidity Texture feature extraction (Haralick features via Labkit) Rule-based 
thresholds aligned with pathological criteria for sclerosis Unlike DL approaches, this workflow: 1.Operates on consumer-
grade hardware with- out specialized accelerators 2. Eliminates training data re- quirements through transparent 
parameterization 3. Pro- vides full algorithmic traceability for clinical auditing The following sections validate this 
ImageJ-based pipeline against pathologist-annotated biopsies, demonstrating competitive ac- curacy with DL models 
while radically reducing computational barriers—offering a practical solution for renal pathology lab- oratories 
worldwide. 

 
2. LITERATURE REVIEW 

These sources collectively focus on the application of machine learning and artificial intelligence in predicting and 
diagnosing kidney diseases, particularly diabetic kidney disease and conditions impacting kidney transplant suitability. 
The "Nakahara et al." paper presents a machine-learning model that predicts a rapid decline in kidney function in type 2 
diabetes patients using a wide range of laboratory tests, identifying key biomarkers beyond traditional indicators. 
Conversely, the "Ayyar et al." and "Altini et al." papers explore deep neural network techniques for classifying renal 
glomeruli from kidney biopsy images as either normal or abnormal, which is crucial for renal diagnosis and evaluating 
kidneys for transplantation. Both sets of research highlight the potential of AI-driven tools to enhance the accuracy and 
efficiency of kidney disease assessment and prognosis. 

Current challenges and future directions for AI in renal pathology are multifaceted, encompassing issues with data, 
model development, clinical integration, and the fundamental understanding of kidney diseases. 

 
2.1. CURRENT CHALLENGES 

Data Scarcity and Annotation Reliability: A primary challenge is the scarcity of reliable annotated datasets that can 
serve as benchmarks for histological investigations in renal diagnosis using digital pathology12. Manual identification 
and annotation of glomeruli are performed by medical graduands and validated by expert pathologists, requiring 
multiple rounds of scrutiny to eliminate incorrect annotations and maintain medical standards and credibility3.... This 
process can be labor-intensive and subjective8. 

Subjectivity and Variability in Manual Assessment: The traditional evaluation of kidney biopsies is a time-
consuming, highly variable, and subjective process performed by trained pathologists using light microscopes. This can 
lead to poor reproducibility among pathologists and potentially inappropriate organ discard8.... 

Dataset Imbalance: Many classification problems, such as distinguishing normal from abnormal glomeruli or 
sclerotic from non-sclerotic ones, inherently reflect the realistic class imbalance often found in medical pathologies12.... 
This imbalance can skew model performance and necessitates careful evaluation using metrics like PR-AUC and F1-score, 
which tend to be lower for minority classes14. 

Complexity of Image Variations: Biopsy images exhibit high congruity and intricate variations, which can lead to 
misclassification even with advanced deep learning models like transfer learning architectures (e.g., ResNet50 and 
InceptionV3 have empirically under-performed for glomeruli classification compared to feature-extracted supervised 
classifiers)1617. Deeper layers of CNNs might be skewed towards higher-level features, potentially losing local spatial 
information critical for intricate medical image details18.... 

Generalizability: Data often originate from a single hospital, which can limit the generalizability of developed models 
to broader patient populations and diverse clinical practices2223. 

Feature Selection and Overfitting: When dealing with a wide range of laboratory tests, challenges include overfitting 
and handling missing data24. While techniques like Recursive Feature Elimination with Cross-Validation (RFECV) can 
help, there's a risk of converging to locally optimal features rather than the absolute best combination2425. Additionally, 
some potentially relevant test values might be overlooked due to insufficient data or correlation with already selected 
features22. 

Confounding Factors: The limited understanding of the underlying mechanisms of conditions like Rapid Decline 
(RD) makes it difficult to accurately identify and control potential confounding factors among laboratory tests25.... 
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Data Characteristics and Preprocessing: Issues like sparse data, the need for interpolation, stain color variation, and 

varying numbers of test values per patient can impact prediction accuracy and data resolution25.... 
Ethical and Privacy Concerns: Restrictions imposed by research ethics committees often prevent medical data from 

being openly available, hindering widespread research and validation efforts3031. 
 

2.2. FUTURE DIRECTIONS 
Development of Comprehensive CAD Systems: A primary goal is to build complete Computer-Aided Diagnosis 

(CAD) systems that can automate renal diagnosis, reducing the burden on pathologists and providing rapid, objective 
results32.... These systems would integrate various analytical modules into a seamless workflow3637. 

Dataset Expansion and Diversification: Future work aims to expand existing datasets like the Glomeruli 
Classification Database (GCDB) to include more granular categories of glomeruli (e.g., Sclerotic, Crescentic)3839. A 
crucial step is also to incorporate Electronic Health Records (EHRs) from multiple facilities to enhance model 
generalizability and representativeness across diverse patient populations22.... 

Improved Predictive Models and Biomarker Discovery: Research will focus on developing machine learning 
models for accurate prediction of conditions such as Rapid Decline (RD) in kidney function, utilizing common laboratory 
tests, and potentially identifying new or alternative biomarkers (e.g., γ-GTP, MCH, Hct)40.... This involves exploring 
factors associated with RD from a broader range of clinical examinations43. 

Enhanced Feature Engineering and Selection: Future efforts will emphasize minimizing empirical assumptions 
in feature extraction, integrating weighted classification, and conducting in-depth feature analysis to identify optimal 
diagnostic indicators45. Strategies to handle imbalanced datasets, such as oversampling methods, will also be 
investigated1436. 

Advanced Deep Learning Architectures: There is an ongoing push to explore and implement more sophisticated 
deep learning models specifically designed for object detection (e.g., Faster R-CNN, Mask R-CNN) and semantic 
segmentation, which have shown promising results3646. Direct comparisons between traditional feature-based 
approaches and deep learning methodologies will also be conducted36. 

Clinical Integration and Impact: The ultimate aim is for AI tools to provide early warnings to physicians, facilitate 
timely referrals to nephrologists, and optimize healthcare resource allocation. This can significantly contribute to 
maintaining patients' quality of life and minimizing healthcare costs by reducing unnecessary procedures27.... Validation 
of these techniques across the full spectrum of lesions encountered in typical nephropathology services is essential49. 

Refinement of Classification Capabilities: Future models aim to distinguish between more nuanced categories of 
glomeruli, such as normal versus partially sclerosed, provided that sufficient high-quality data for these specific 
distinctions become available50. 

Adaptability to Diverse Staining Protocols: Efforts will be made to extend the AI paradigms for identifying and 
segmenting glomeruli to images generated using various staining protocols, beyond just trichrome or Periodic acid-Schiff 
(PAS) stains, to ensure broader applicability in diverse clinical settings 

 
3. METHODOLOGY 

Workflow for Glomeruli Segmentation Using ImageJ 
1) Preparation 
Open your histology image (e.g., PAS, H&E stained). 
Ensure it's a high-resolution, color image (TIFF or JPEG preferred). 
2) Preprocessing 
Convert the image to grayscale or extract a color channel if needed: 
Image → Type → 8-bit or use Image → Color → Split Channels 
Optional: Enhance contrast 
Process → Enhance Contrast or Process → Filters → Gaussian Blur 
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3) Thresholding 
Use Image → Adjust → Threshold 
Adjust sliders to isolate glomeruli (typically darker/lighter structures depending on staining). 
Apply threshold: Click “Apply”. 
4) Segmentation 
Use Analyze → Analyze Particles to detect and outline glomeruli. 
Set size (e.g., 5000-Infinity pixels²) 
Enable “Display Results”, “Exclude on Edges”, and “Add to Manager” 
5) Manual Correction (if needed) 
Use drawing tools (freehand selections) to manually add missed glomeruli or remove artifacts.  
Add manual selections to ROI Manager. 
6) Quantification 
From the ROI Manager, use More → Measure to get area, perimeter, etc. 
Export data as CSV or Excel. 
 

 
Figure 1 Procedure for Medical image segmentation 

 

 
 
 
 
 
 
 
 
Table Comparision of segmentation metrics for existing    studies and proposed technique 

Source Model F-
Score 

Precision Recall IoU 

Nicola(2020) 
  

 Deep 
Learning 

0.92 0.97 0.91 0.80 

Meghana 
Ayyar(2018)  

AI 0.88 0.89 0.88 -- 

SatishKumar 
(2022) 

CNN 0.63 0.95 -- -- 

Proposed 
Study 

ImageJ 
Random 
Forest 

0.98 0.98 0.97 0.98 
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4. RESULTS AND DISCUSSIONS 

 
Figure 2 Kidney WSI 

 

 
Figure 3 WSI viewed in HSB space and converted to binary 

 

 
Figure 4 Segmented WSI using LabKit 

 

 
Figure 5 Mask with scerotic, non-serotic,background. 
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Figure 6 Results for precision, recall 

 
Sclerotic and non-sclerotic diabetic nephropathy represent two histological patterns of kidney damage caused by 

diabetes, and they have distinct pathological features and clinical implications. 
Sclerotic Diabetic Nephropathy 
Definition: Characterized by irreversible scarring (glomerulosclerosis) of the glomeruli due to prolonged diabetes-

induced damage. 
Histological Features: 
Nodular glomerulosclerosis (Kimmelstiel-Wilson nodules) 
Thickened glomerular basement membrane (GBM) 
Hyalinosis and arteriolar sclerosis 
Loss of capillary lumens 
Clinical Significance: 
Advanced stage of diabetic kidney disease 
Associated with decreased glomerular filtration rate (GFR) and proteinuria 
Poor prognosis 
Non-Sclerotic Diabetic Nephropathy 
Definition: Early stage of diabetic kidney damage where glomeruli are still intact without significant scarring. 
Histological Features: 
Mild mesangial expansion 
Minimal to no glomerular scarring 
Thickened GBM (may be present) 
Absence of nodular lesions 
Clinical Significance: 
Reversible or manageable with proper glycemic and blood pressure control 
Earlier detection may improve long-term renal outcomes 
Manual image segmentation is a foundational step in biomedical image analysis, enabling accurate identification of 

regions of interest (ROIs) such as glomeruli in kidney tissue. Labkit, a plugin in ImageJ/Fiji, offers an intuitive interface 
for manual and semi-automated segmentation using machine learning classifiers. This report focuses on manual 
segmentation using Labkit to create ground truth annotations for biological image analysis. 

Manual segmentation produced high-fidelity label masks delineating glomeruli. These annotations can serve as 
ground truth for: 

Quantitative morphometric analysis 
Training machine learning models 
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Validation of automated segmentation tools 
Manual labeling accuracy depends heavily on user expertise and image quality. Time per image ranged from [insert 

time] depending on complexity. 
Labkit offers a streamlined interface for manual annotation. While labor-intensive, manual segmentation ensures 

high accuracy, especially valuable for creating initial training data or validating AI-based tools. Limitations include 
operator bias and time consumption. Future work can involve semi-automated tools or training Labkit’s classifier for 
improved efficiency. 

Manual segmentation using Labkit in ImageJ is a reliable method for generating accurate image annotations in 
biomedical research. Despite its time requirements, it remains an essential tool for precise ROI delineation and the 
development of automated image analysis pipelines. 

Labeling in Labkit (ImageJ) is the process of assigning classes (like "glomeruli", "tissue", "background") to pixels in 
an image by painting them manually or semi-automatically.  

To observe precision and recall in ImageJ, especially after segmentation (e.g., using Labkit), you need a ground truth 
mask and a predicted segmentation mask. Precision and recall are not calculated directly in basic ImageJ, but can be 
derived using Fiji plugins or manual pixel comparisons. 

Steps to Calculate Precision & Recall in ImageJ (Fiji) 
 Requirements: 
• Ground truth mask (e.g., from manual labeling) 
• Predicted segmentation mask (e.g., from Labkit or another classifier) 
Manually Using Image Calculator 
• Load Ground Truth and Predicted Mask images. 
• Use Process > Binary > Convert to Mask if not already binary. 
Use Process > Image Calculator to perform: 
• AND operation → True Positives (TP) 
• Ground truth - Prediction → False Negatives (FN) 
• Prediction - Ground truth → False Positives (FP) 

  

 
Figure 7 Ground truth mask for non-scerotic glomeruli 
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Figure 8 Ground truth mask for scerotic glomeruli 

 
The segmentation performed using Labkit shows high accuracy, with F1 scores consistently above 0.98. Precision 

was generally higher than recall, indicating the method was conservative in labeling, with fewer false positives than false 
negatives. These results validate the reliability of the classifier-assisted segmentation when paired with manual 
corrections. 

Image analysis is crucial in fields such as histopathology, cell biology, and materials science. ImageJ, a public domain 
Java-based image processing software developed by the NIH, provides a versatile platform for analyzing, processing, and 
quantifying features in images from various scientific domains. 

ImageJ supports a wide range of image formats (TIFF, JPEG, PNG, DICOM, etc.) and offers essential tools for editing, 
filtering, segmentation, and measurement. Its plugin architecture and macro support make it highly customizable for 
specialized tasks. 

ImageJ is a powerful tool for image analysis in research, enabling accurate, efficient, and reproducible quantification 
of complex visual data. Its flexibility and accessibility make it a preferred choice in many scientific disciplines. 

 
5. CONCLUSION 

ImageJ Labkit provides a user-friendly, efficient, and accessible platform for biomedical image segmentation, 
especially in scenarios where annotated datasets are limited or rapid prototyping is essential. Unlike CNN-based deep 
learning models that require large annotated datasets, significant computational resources, and programming expertise, 
Labkit enables researchers to perform accurate segmentation with minimal training data and intuitive manual correction 

While ML and CNN approaches offer superior performance in large-scale and high-complexity tasks due to their 
ability to learn intricate features, they also involve longer setup times, dependency on quality annotations, and model 
tuning. Labkit, in contrast, shines in practical, smaller-scale laboratory environments where expert supervision and 
iterative refinement are critical. 

Therefore, Labkit serves as a strong alternative or complementary tool to ML and CNNs for biomedical 
segmentation—bridging the gap between manual annotation and advanced automation. 
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